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0 Quickstart guide 

0.1 Things you can't find out by playing 

(This part should be read by experts who consider reading instructions a waste of time.) 

The assembly of the FT8-box should not be a problem. Make sure that VCC (red) and GND 

(black) are crossed on the GPS cable! 

The FT8 box contains a Raspbery Pi 3B - a compromise between power consumption and 

speed - which is set up as an access point (AP) 

AP-address:  10.3.141.1 

SID:  FT8--Box 

Password:  FT8--Box  (also applies to all passwords on the Raspi) 

Login:  wsjtx  (also applies to all passwords on the Raspi) 

Auf diese AP-Adresse wird mit VNC1
 vom Smartphone, iPhone (oder PC) zugegriffen. Wenn 

zusätzlich durch ein Ethernet-Kabel (RJ45) Verbindung zum Internet hergestellt ist (Shack-

Betrieb), synchronisiert sich die FT8--Box über einen NTP-Timeserver. Im Portabel-Betrieb 

(kein Internet verfügbar) wird diese Synchronisation über den GPS-Unit geliefert, wenn das 

fehlschlägt, kann man einen SNTP-Server auf dem Smartphone bzw. NTP-Server auf dem 

iPhone starten. (Installation Time Server App2
 über Google Play, Installation von NTP 

TimeSYNC3
 über App).  

This 
A
P address is accessed with VNC1

 from Smartphone, iPhone (or PC). If an Ethernet cable 

(RJ45) is also used to connect to the Internet (Shack mode), the FT8-box synchronizes via an 

NTP time server. In portable mode (no internet available) this synchronization is provided by 

the GPS unit, if this fails, you can start an SNTP server on the smartphone or NTP server on the 

iPhone. (Install Time Server App
2
 via Google Play, install NTP TimeSYNC3

via App Store). 

Using this AP address (entered into the browser via VNC) the AP-IP settings can be changed 

(caution!!!). The AP address also runs an FTP server, so that you can access the files from out-

side. 

In addition to using AP access, client access to an existing network is possible (set WiFi in the 

top right corner). This allows you to create a HotSpot on the summit with your smartphone and 

use it to control the FT8 box. The smartphone can then connect to the Internet (note the IP 

address  for VNC connection at first setup, when you are still at home) 

The SD card is permanently bound to the Raspi board via a hardware code. It will not run on 

another Raspi. (Copying the SD card for another Raspi will cause a crash during boot). 

If you get stuck, read the manual or look at the Trouble Shooting section. 

  

https://www.realvnc.com/de/connect/download/viewer/
https://timeserver.app/
https://www.deepaso.com/app/tr/1089074515
https://www.deepaso.com/app/tr/1089074515
https://www.realvnc.com/de/connect/download/viewer/
https://timeserver.app/
https://www.deepaso.com/app/tr/1089074515
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1 About FT8--Box de HB9HCI 

1.1 Overview 

The FT8--Boxis a simple way to use your transceiver to encode/decode FT8-Signals.  It con-

sists of a RaspberryPi3B computer, Soundstick USB soundcard and a GPS receiver.  Your 

Smartphone or tablet is used as the 

input device to control the RasPi. 

 

In this manual you will find a descrip-

tion of the FT8--Box Kit and an intro-

duction to the use of the FT8--Box. In 

particular how to use the WSJT-X 

program to successfully make SOTA 

contacts with FT-8. 

1.2 Function 

The FT8--Box contains a Raspi 3B4
, which runs the Rasbian5

 operating system (a Linux 

derivative). WSJT-X6
, the actual FT8 program, runs under the Rasbian OS. The FT8 protocol 

requires synchronization with UTC (world time). The FT8--Box gets the time from the Internet, 

when the Ethernet interface is connected to the Internet, from the connected GPS, if it gets a 

fix, or from the smartphone/iPhone.  

The FT8--Box creates its own WiFi FT8--Box as access point, over which the display device 

(Android/iPhone smartphone or tablet) connects to the FT8--Box. 

If the FT8-box is connected to the Internet via the Ethernet cable, the box can also be used for 

other purposes: for instance, it can serve as an access point for a domestic guest wifi. 

1.3 Requirements 

 FT8--Box DIY-Kit 

 USB-power supply (5V/0.5A) for the FT8--Box  

 Smartphone/Tablet (Android) or iPhone/iPad (iOS) as display. 

 Transceiver  

During setup, internet access is required to install two utility programs on the display device. 

1.4 Setup 

Before use the following steps need to be completed: 

 Assemble the Box (=>2 Assembling) 

 Installation of a virtual screen on the Smartphone/iPhone (VNC) (=>3.2 Settings) 

 Setup time synchronisation (=>4 Time Synchronisation) 

 Setup WSJT-X software and connection to radio (=>5 Initial Set Up of FT8--Box ) 

When using the FT8-Box the required steps are : 

 Connect tranceiver to FT8 box 

 Switch on 

 Synchronize time 

 Start FT8 program  

 Make FT8-QSO's  

 

  

https://de.wikipedia.org/wiki/FT8
https://de.wikipedia.org/wiki/Raspberry_Pi
https://en.wikipedia.org/wiki/Raspbian
https://physics.princeton.edu/pulsar/K1JT/wsjtx.html
https://www.qsl.net/hb9hci/Pages%20DE/kit.html
https://www.qsl.net/hb9hci/Pages%20DE/setting.html
https://www.qsl.net/hb9hci/Pages%20DE/setting.html
https://www.qsl.net/hb9hci/Pages%20DE/prepare.html
https://www.qsl.net/hb9hci/images/FT8--Box.jpg
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2 Assembly of the FT8--Box 

 The assembly is done from top to bottom as shown in the adjacent figure: 

 

The upper face is screwed to the housing with 

4 cross-head screws. (Thick edge to the bot-

tom of the housing.) 

 

 

The cover plate (shown left) is pushed into the 

housing from below. 

 

 

 

 

 

 

The two hexagonal spacers are inserted into 

the board from the rear (solder side) next to 

the connector strip and fixed with the two 

nuts. 

 

Glue the three heat sinks onto the matching 

chips. The flat one with the Raspi logo goes 

on the chip on the bottom of the board.  

 

The PCB is inserted into the housing so that 

the spacers are aligned with the holes in the 

bottom of the housing. Make sure that the 

sockets (4xUSB, RJ45) on the board are in the 

corresponding housing cutouts. 

 

Fasten the board to the bottom of the housing 

with the two cross-head screws. 

 

Put the cable for GPS (see 2.1 Installation 
GPS Unit) through the lower front face 

(through the long slot) and fix it with the 4 

cross-head screws. (Fit SD card into the cor-

responding slot). 

  

https://www.qsl.net/hb9hci/images/zusammenbau.jpg
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2.1 Installation GPS-Unit 

When installing the GPS unit, first insert the cable through the slot of the lower panel. To do 

this, insert the plug across the slot. (yes it does fit with a bit of pressure) 

 Unfortunately the 

supply lines 

(5V,GND) of the 

GPS unit must be 

crossed to match 

the pin assignment 

of the Raspi: 

 

Lift the plastic spring with a pin and then pull out the 

black and the red wire. (See picture). 

 

 
(Thanks Tom, HB9BRH, 

 for the tip with the pin) 

 

 

 

 

Then insert the two metal contacts (swapped over) 

back into the corresponding holes of the plastic plug. 

(see picture). 

 

 

 

 

 

Unfortunately, the grid spacing of the connector strip 

and the GPS unit connector is different, but with a 

little bit of bending, a proper contact is achieved. 

  

 

 

 

  

Finally stick the GPS unit to the housing 

with the enclosed double-sided adhesive 

patch. 

  Important: 

The 1st pin on the Raspi socked is not connected! 

The outer line of the socked is used. (see picture). 
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3 FT--8 Box Access Settings 

3.1 Accesspoint 

The FT8--Box is connected to a 5V 

USB power source using the supplied 

USB cable (next to the video socket - 

see picture). (Consumption approx. 

200mA) For portable use (SOTA) 

accupacks
7
 have proven to be the best 

choice. The chosen Raspi version 

(3B) is a compromise between speed 

and power consumption. 

As soon as voltage is applied, the 

FT8-box boots and offers its own 

WiFi network: FT8--Box. This network is password protected.  

Password: FT8--Box (note: 2 minus signs!) This network the uses the address 10.3.141.1, and 

allows three different methods of access: 

VNC:  Terminal access is available with the help of a VNC program (to be installed). On the 

Tablet/Smartphone/iPhone/PC the virtual screen of the FT8--Box appears as own 

window 

FTP:  The URL ftp://10.3.141.1 provides access to the file system of the FT8--Box. 

HTTPS:  With the URL https://10.3.141.1 the settings of the access point of the FT8--Box can 

be changed. (Be careful if you do make changes: you can block your access to the 

FT8--Box. In this case you have to connect a keyboard and mouse to the free USB 

ports and a (real) screen to the HDMI socket). 

3.2 Access via WiFI Home-Net/HotSpot 

(Experimental) Instead of using AP FT8--Boxwifi access, 

you can use your own home WiFi network or the hotspot 

of your smartphone to access the Raspi system. To do so, 

you first have to establish a connection via the AP with 

VNC. The host network must already be running. Now 

this network is selected as another network in the upper 

right corner and provided with the corresponding net-

work password. To remember the set address move the 

mouse over the WiFi icon, then the IP address in the host 

network will appear as tooltip. This address you need to 

establish the VNC connection. 

  



HB9HCI    FT8--Box    DIY  V. 2.2.3en 

9 

 

3.3 Establishing a connection to the FT8--Box 

A VNC app must be installed on the 

device that is the display and control for 

the FT8 box. See: VNC-Installation 

To establish a connection to the FT8--

box, the access point address 10.3.141.1 

must be entered in VNC. (via HotSpot 

see below) 

Login:  wsjtx 

Password:  FT8--Box 

It is advisable to save this access (login, 

password) so that you do not have to 

enter it again each time.  

The start screen of the FT8-box will 

open. On the top left is the menu button 

(Raspberry). The FT8--Box programs 

are in the HAM-Radio folder.  

 

The mouse operation of the VNC program takes some practice on Smart- and iPhone, because 

the mouse pointer is not directly under the finger like on a touch-screen, but moves parallel to 

the finger. But this has the advantage that you can easily see where the mouse pointer is. The 

operation is described in the VNC program itself and here
8
. The mouse keys and the keyboard 

become accessible if you tap with the FINGER (not with the mouse pointer) into the header of 

the VNC program. (See also footnote
1
) 

3.4 Synchronisation 

The Raspi does not contain a real time clock: when it boots, the internal (software) clock starts 

at 0:00. Since the FT8 protocol works with strict time slots (a new slot starts every 15s), the 

system must be synchronized with UTC (world time). There are 3 options in order of prefer-

ence: 

 The FT8--Box synchronizes with the GPS-receiver outdoors. (4.1) 

 The FT8--box is connected directly to the Internet via the Ethernet interface. Then the 

clock is automatically set to UTC with the help of an NTP server via the Internet. (4.2) 

 Using your VNC connected device to receive a GPS time signal (4.3 Android Setup or 

4.4 iPhone Setup) 

 

 If there is a GPS signal to your Android device then 

the time can be taken from this device via an SNTP 

server. See: 4.3 Setup SNTP-Server 

 If a connection with an iPhone/iPad is established, 

the time is taken from the NTP server running there. 

See: 4.4 Setup NTP-Server 

As soon as the connection is established, the time 

query must be triggered. This can be done with a 

double click on the SyncTime-Icon or by clicking 

on the corresponding menu line  

(see figure right). 

 

https://www.realvnc.com/en/connect/download/viewer/
https://play.google.com/store/apps/details?id=com.realvnc.viewer.android&gl=GB
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The SyncTime app 

acknowledges suc-

cess: 

 

 

or failure: Most of 

the time you have 

forgotten join the 

FT8--Box Net.  

The other common error is that you did not start the app (or in case of Android, did not start the 

server additionally). 

If the synchronization is successful, you can start the FT8 program (WSJTX)... 

  

https://www.qsl.net/hb9hci/images/synctime-no.JPG
https://www.qsl.net/hb9hci/images/synctime-yes.JPG
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4 Time Synchronisation 
FT4/FT8 (and other modes) require the real-time clock to be synchronized with UTC, as the 

individual time slots in which the data is transmitted start every 15 sec (FT8) or 7.5 sec (FT4) 

after the full UTC minute. This means that transmission takes place in 4 slots for FT8 (twice to 

and fro) and in 8 slots FT4 (four times to and fro). 

The accuracy of this synchronization is shown in WSJTX in the DT (DeltaTime) column. If 

the deviation is greater than +/ 2 sec, decoding will fail. Therefore it is important to make sure 

that the internal clock is as close to UTC as possible. (The time zone does not play a role in 

this). 

The Raspi does not contain a real time clock: when it boots, the internal (software) clock starts 

at 0:00. Since FT8--Box V2.0, there are 3 different methods to perform time synchronization. 

 The FT8--Box synchronizes with the GPS-receiver outdoors. (4.1) 

 The FT8--box is connected directly to the Internet via the Ethernet interface. Then the 

clock is automatically set to UTC with the help of an NTP server via the Internet. (4.2) 

 Using your VNC connected device to receive a GPS time signal (4.3 Android Setup or 

4.4 iPhone Setup) 

4.1 GPS-Receiver 

Outdoors, this synchronization is per-

formed automatically. As soon as the 

GPS receiver has calculated a fix (valid 

coordinates), it starts flashing bluish. The 

software clock in the FT8--Box will then 

be readjusted automatically. (It can take 

up to 5 min. until a fix) 

The reception of GPS 

signals can be displayed 

with the app GPS-Data 

(FT8--Box: Menu=>Ham 

Software => GPS => 

GPS-Data). If there is no 

reception for more than 5 

minutes: Start SyncTime 

on the FT8--Box.  

 

 

 

 

Alternatively start WSJTX 

(SOTA). This will show when you 

have a valid fix and locate the 

nearest SOTA summit. This data is 

then immediately entered into the 

WSJTX program. 

Here you select the next summit (in 

the picture: „Gempen“, which here is still 4.6 km away in direction NW (38°), 760m high, 1 

SOTA point but 0 bonus points for activation). 
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4.2 NTP-Server with Ethernet-Connection to Internet 

The clock is automatically synchronized via NTP, when connected to the internet via the RJ45 

socket. (Shack mode) 

4.3 Android-SNTP Server Setup 

From Google Play download and install the 

TimeServer9
. This app reads the time from the GPS 

signal, which only works when GPS satellites are 

received by the smartphone (outdoors). An SNTP 

server is integrated into the app, which must also be 

started. 

There is a radio button: NTP-Server auto-start (start NTP server 

automatically). You should select this option so you can save your-

self this additional step in fu-

ture. Then it is sufficient to start 

the TimeServer app only.  

 

As soon as the connection is 

established, the time query must 

be triggered. This can be done with a double click on the 

SyncTime-Icon or by clicking on the corresponding menu 

line  

(see figure right).  

 

 

 

 

 

 

 

The SyncTime app ac-

knowledges success: 

 

or failure: Most of the time 

you have forgotten join the 

FT8--Box Net.  

The other common error is 

that you did not start the app (or in case of Android, did not start the server additionally). 

If the synchronization is successful, you can start the FT8 program (WSJTX). 

The process looks like this: 

 Login your Smartphone into FT8--Box Wifi  

 Start TimeServer-App. (If necessary, start the NTP server additional.) 

 Start VNC-App  

 In VNC-App SyncTime via Menu=>Ham-Radio or double click and wait 

for results 

 Start FT8-Program wsjtx via Icon or Menu=>Ham-Radio 

 

 

https://play.google.com/store/apps/details?id=app.timeserver&hl=en
https://play.google.com/store/apps/details?id=app.timeserver&hl=en
https://play.google.com/store/apps/details?id=app.timeserver&hl=en
https://play.google.com/store/apps/details?id=app.timeserver&hl=en
https://www.qsl.net/hb9hci/images/synctime-no.JPG
https://www.qsl.net/hb9hci/images/synctime-yes.JPG
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4.4 Setup iOS-NTP-Server (iPhone/iPad) 

Download and install the NTP Time Sync from the App Store. If you get 

it! It seems, that the chinise company has removed this app from the 

appstore. 

This app was apparently developed for Siemens S7 controllers, but it 

does its job fine. 

 

 

 

As soon as the connection is established, the time query must 

be triggered. This can be done with a double click on the 

SyncTime-Icon or by clicking on the corresponding menu 

line  

(see figure right). 

 

 

 

 

 

 

 

The SyncTime app ac-

knowledges success: 

 

 

or failure: Most of the time 

you have forgotten join the 

FT8--Box Net.  

The other common error is 

that you did not start the app (or in case of Android, did not start the server additionally). 

If the synchronization is successful, you can start the FT8 program (WSJTX). 

 

Procedure for starting the FT8 program: 

 Login: iPhone/iPad into FT8--Box Wifi-net. 

 Start NTP Time Sync. 

 Start VNC-App (IP-address 10.3.141.1, Login: wsjtx Password FT8--Box 

 In VNC-App SyncTime via  

Menu=>Ham-Radio or double click on the icon and wait for receipt.  

 On iPhone bring NTP Time Sync to the foreground. wait 10s, then back 

to VNC app 

 Start FT8-Programm wsjtx via Icon or via Menu=>Ham-Radio. 

 

  

https://play.google.com/store/apps/details?id=app.timeserver&hl=de_CH
https://www.qsl.net/hb9hci/images/synctime-no.JPG
https://www.qsl.net/hb9hci/images/synctime-yes.JPG
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5 Initial Set Up of FT8--Box 

5.1 FT8--Box and Transceiver Connections 

 Plug the sound stick into the USB socket and connect the transceiver (if not sending the 

sound via USB line):  

FT8--Box Connection Transceiver Connection 

Microphone Headphones 

Headphones Microphone 

 

 if applicable, connect the rig control for the transceiver to the USB socket 

After the time is successfully synchronized (4), start two programs on the FT8--Box: 

  LastQSO's. This program reads the WSJT-X log every 10s and displays the 

last QSO's with comment field (for SOTA: Summit identifier) (top right on 

the desktop) 

 FT8 program: WSJT-X. Start using the Menu Entry  

Menu=>Ham-Radio or by double clicking on the corresponding icon. 

5.2 Settings in WSJT-X 

The following settings are important for the FT8--Box to work.  For a full description of the 

software look at the WSJT-X manual
6
 or 

https://www.g4ifb.com/FT8_Hinson_tips_for_HF_DXers.pdf
11

. 

5.2.1 Audio 

First, the sound card is 

auto-detected. If this does 

not happen, there will be 

some error messages. In 

this case, click on the 

Audio tab under File=>Settings. The two 

upper fields must be filled in. Usually the 

setting "Default" works; otherwise have a play. 

(If "Default" doesn't work, often line 2 is used 

for receiving and the last line for sending. 

More information about individual transceivers  

can be found on the WebSite 

https://ft8--box.hb9hci.support .) 

5.2.2. Radio 

Settings for the tab, Radio (File => Settings), depend on, 

 Is the Transceiver driven by the FT8--Box (via USB) 

 Is the Transceiver driven by VOX and Microphone 

5.2.2.1 Transceiver driven by FT8--Box 

If the transceiver allows an additional USB connection (with an appropriate cable), use this 

connection. This connection requires setting a serial port and baud rate. The baud rate is 

usually configured in the transceiver. You have to enter this setting in the tab Radio. (The other 

serial settings may have to be adjusted).  If you use rig control in your shack, look at the con-

figuration on your shack computer. 

https://www.g4ifb.com/FT8_Hinson_tips_for_HF_DXers.pdf
https://ft8--box.hb9hci.support/Pages_DE/FAQ.html
https://ft8--box.hb9hci.support/images/Rigfehler.jpg
https://ft8--box.hb9hci.support/images/Audio.jpg
https://ft8--box.hb9hci.support/images/SoundFehler.jpg
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The serial port is /dev/ttyUSB0. Under Rig you select your transceiver. PTT Method is 

"CAT". In the transceiver, switch off VOX . (If you forget this, the transceiver gets out of sync, 

because it would be controlled by CAT as well as by VOX) 

Data/Pkt is the recommended Mode: The transceiver will then use the appropriate filter set-

tings. (If Data/Pkt is not an option/suitable on your transceiver then use SSB, e.g. because the 

filter bandwidth cannot be set in Data-Mode (as with the FT991). Note: FT-8 uses USB on all 

bands). 

Split operation allows you to set whether the transmitter should be adjusted by 500Hz for low 

sounds, so that any band passages in the audio are bypassed. Recommendation Fake It setting 

5.2.2.2 Transeiver driven via VOX 

If the transceiver cannot be computer controlled, or you want to use the VOX control, set the 

PTT Method to VOX. In addition the transmitter must also have VOX "on" (with correspond-

ing settings for the threshold, which triggers VOX and switch to transmit). The transmitter is 

then controlled by the microphone signal. To adjust these settings on the transmitter, there is a 

Tune button on the main WSJTX window: the program will continue to transmit a tone until 

Tune is pressed again. When using the VOX control, be careful not to use a stereo cable for the 

microphone line, as transmitter microphones usually have a PTT button that uses the second 

channel of the cable. (If necessary, set PTT to "off" in the transmitter). 

5.2.3 Settings for SOTA 

An identification for the summit must be 

transmitted for SOTA operation, so it is 

recommended to prepare a macro with the 

corresponding entry. As FT8 uses trans-

mits a maximum of 15 characters per time 

slot, the identifier has to be shortened a 

bit. This entry is made automatically when 

starting with WSJTX (SOTA). 

5.2.4 Colour-Setting 

In the Colors Tab you can set the colors. Compared to the standard settings I changed the 

active QSO's (received QSO's) to blue for better readability. Here you can configure your own 

colours. 

5.2.5.General Settings 

In the tab General some basic settings are preconfigured. Here you have to enter the callsign 

My Call (don’t forget to change to the corresponding country code e.g. G to GM) and the 

current position (My Grid). A detailed description of the individual fields is available here. 

5.3 Settings - Transceiver 

Since there are different types of transceivers, only the 

basic settings can be described here:The audio cable 

from the phone output of the receiver to the input of the 

soundstick should be a mono cable or must be shielded, 

otherwise HF radiates into the soundstick and distorts 

the transmitted audio signal. 

 For the audio cable into the microphone input of 

the transmitter, a Tiptop Audio Stackable10
 

(not included) is recommended, so that you can 

check the audio signal sent by the soundstick for 

purity (interference by HF) with an earphone. 

Attention: The 2nd audio channel (stereo) is 

used for PTT with some transceivers. With the 

https://www.sota.org.uk/
https://www.schneidersladen.de/de/tiptop-audio-stackcable-55cm-yellow.html
https://ft8--box.hb9hci.support/images/Sota-Makro.jpg
https://ft8--box.hb9hci.support/images/RadioTab.jpg
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supplied mono cable this should not be a problem. For stereo lines, switch off PTT if 

necessary) 

 If the transceiver has a DATA setting, make sure that no shaping filter is effective (no 

PSK, RTTY etc). The filter settings should allow a bandwidth between 0.5 and 3KHz. 

 The modulation level should be set so that the full (QRP) transmit power is delivered 

but no overmodulation occurs. (Check the transmitted signal with a receiver) Set the 

SoundStick's output signal to max (right slider in the WSJT-X main window) to make 

this line as low impedance as possible. Adjustments are made using Tune in the WSJT-

X main window, where a continuous tone is sent. 

 If the transceiver is controlled via a USB line (CAT control), set the VOX control to 

"off" for safety reasons, so that both controls do not interfere with each other. 

 If TX control is to be performed without a USB connection to the transceiver, the VOX 

setting must be set so that the transceiver only goes on air when there is a signal at the 

microphone input. (Adjust using Tune (in the main window of WSJT-X)). 

 Adjust the output signal of the receiver so that the receive bar (on the left side of the 

WSJT-X main window) remains in the green area. (Do not overlaod.) 

 Do not forget: Before first transmission, adjust the automatic tuner (ATU) - if avail-

able - to the antenna. 
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6 Use 

6.1 Requirements 

 The virtual screen (VNC) should be installed and set as described in 3.3. 

 Time synchronization should be completed as described in 4. 

 The settings for WSJT-X should be as 5.2. 

 The transceiver should be set as described in 5.3. 

6.2 Start FT8 

Double-click on the WSJTX icon or via Menu => Ham Radio => WSJTX to start the FT8 

program. Two windows will open. The split, window shows the spectrogram of the input signal 

in the bottom and above a waterfall display.  The other window is the WSJT-X main window. 

6.2.1 Waterfall Display 

It is important that the green 

horizontal lines are located at the 

start or end points of the vertical 

colored bars. If this is not the 

case, the time synchronization is 

not correct and no signals are 

decoded (left list box remains 

empty). In this case repeat time 

synchronization (4). 

The waterfall allows you to view the activity on the band.  Keep an eye on this waterfall win-

dow, because the free frequencies (blue/black) are visible here. In the header of this window is 

a frequency scale. If you move the mouse pointer there, it changes into a small cross. (with 

VNC under Windows the pointer does not change) A <shift>+mouse click sets the transmit 

frequency to the frequency located under the cross (red mark). The green mark (selected by a 

single mouse click) shows the receive frequency selected for the receive list field (on the right 

of the WSJTX main window). However, all frequencies are decoded. The remaining frequen-

cies are displayed in the left receive list field of the WSJTX main window. 

The waterfall window has a Control radio button in the upper left corner. With the sliders that 

now appear below the window you can adjust the settings for waterfall and spectrum. 

6.2.2 Main window WSJT-X 

It consists of different parts: 

 List window Band Activity. which shows all decoded operations on the band. 6.2.2.1 

 list window Rx Frequency, which decodes my transmitting activity (and the receiving 

frequency selected in the waterfall window). 6.2.2.2 

 Button bar in the middle, with which individual functions are triggered. 6.2.2.3 

 parameter part, displaying time, band, receive level and data of the selected QSO part-

ner. 6.6.2.4 

 QSO-Text 6.6.2.2 

6.2.2.1 Band Activity 

This contains a list of decoded signals with the following meaning: 

UTC: World Time 

dB: Received signal strength in dB (noise ratio) 

DT: Deviation from the Raspi time in s. These values should be on average < +/- 0.5s. If the 

values are significantly larger, the time synchronization is poor. (See 4) 

Freq: Frequency of received signal in audio spectrum (position on waterfall scale) 

https://qsl.net/hb9hci/Pages%20DE/setting.html
https://qsl.net/hb9hci/Pages%20DE/prepare.html
https://qsl.net/hb9hci/Pages%20DE/use.html#52%20Einstellungen
https://qsl.net/hb9hci/Pages%20DE/use.html#53%20Transceiver
https://qsl.net/hb9hci/Pages%20DE/prepare.html
https://qsl.net/hb9hci/Pages%20DE/prepare.html
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Message: The decoded text appears here. The colors are defined under File => Settings in the 

Colors tab (5.2.4). The display of the country code is set in File => Settings Tab General. If 

the box CQ only is checked, only the CQ calls are listed here. Under Menu => Decode => 

Enable IP, WSJTX can estimate the callsign from previous connections. This saves some 

computing time. 

The decoding of the signals is very CPU-intensive. So if there are many stations on the band, 

the decoding will take a lot of time. In such a case I switch the decoding to normal or fast. 

(Menu => Decode). Otherwise the received line is decoded only after the transmission of a 

response has already started. This is probably (with patient QSO partners) no problem, but it 

leads to the fact that the whole QSO takes a little longer. 

6.2.2.2 Rx Frequency 

In this list my QSO is shown. (transmissions in yellow, 

reception in blue). 

After some CQ calls SP9AK answers here and gives its coordi-

nates (JO90). My answer contains the reception strength of 

SP9AK (-8dB). He answers with the reception strength of my 

signal (-15dB). I answer him with RR73. This is the end of the 

QSO and it is recorded in the log. 

Below the list are the 

individual lines that can 

be sent by me. The 

second last line has a 

special meaning: Here I 

can choose if I want to 

send a special text. This 

is where I would enter 

identification of the 

SOTA summit. This can be selected from the pull-down 

menu. (Setup: 5.2.3) 

For the simple transfer of the QSO's into the SOTA database the program wsjtx2sota (as icon 

on the desktop or via Menu => Ham-Radio => wsjtx2sota) converts the wsjtx-log into a 

suitable SOTA.csv-file. To make sure that this works without errors, the corresponding Sum-

mit-identifier must be in the field Comments in the log, e.g. HB/BL-002 

With the radio buttons under Next you can select the next send step. Normally you will mainly 

select Tx6 for a new CQ call. But also for the transmission of the Summit identification (TX5) 

a selection can be necessary, which the program switches off the transmitter by itself after a 

logged QSO (Enable becomes grey) and jumps to TX6. If one clicks on a button under Now, 

the current transmission process is aborted and the clicked line is transmitted. (This may be 

necessary if the remote station can't get out of a loop and is sending the same line all the time.) 

By clicking on a line in the left list Band Activity you can also answer a CQ call. (If your 

callsign has no additions (no country code for international calls nor /p for portable) you can 

speed up the transmission by double clicking on the topmost radio button of Next, then this line 

is skipped for the QSO. 

The + in the Rx Frequency window (between Freq and Message) is an indication of the mode 

used: +: FT4 ~: FT8 

6.2.2.3 Toolbar 

At the centre of the WSJT-X main window are the following buttons: 

 

CQ only: only CQ calling stations are displayed in the left list box. 

https://ft8--box.hb9hci.support/Pages%20DE/use.html#524%20Colors
https://ft8--box.hb9hci.support/Pages%20DE/use.html#523%20SOTA
https://ft8--box.hb9hci.support/images/ButtonLeiste.jpg
https://ft8--box.hb9hci.support/images/rxFrequency.jpg
https://ft8--box.hb9hci.support/images/logQSO.jpg
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Log QSO: window for the log entries 

Stop Monitor: Switch monitoring (decoding) on/off 

Erase: single click deletes left list, double click deletes right list 

Decode: triggers the (re)decoding of the last lines 

Enable Tx: after logging a QSO the station is disabled. This is to prevent stations from work-

ing without operator intervention (as robots). Important: Each time the log window is opened, 

the station must be enabled again. In contrast to Stop Tx, Enable Tx executes the last com-

mand to the end. 

Halt Tx: current transmission is cancelled. 

Tune: to adjust the station, a continuous tone is generated until Tune is pressed again. 

Menus: with a check mark in this field the menu line in the header of the window is hidden. As 

a result, more lines are displayed in the list boxes. 

6.2.2.4 Remaining fields 

The remaining fields provide information about the 

QSO partner, the time of origin, the selected band 

and some settings for sending and receiving, which 

will be described in detail here. 

The pull-down Frequency menu allows the band to be selected. If the transceiver is connected, 

this selection is also passed on to the transceiver. The frequency corresponding to the selected 

mode (FT8/FT4 etc.) appears in the upper black display. If there is a connection to the trans-

ceiver, the circle is marked with a green S, otherwise it is red. 

Below the frequency display, the last station called and its locator are displayed. Below that we 

see the bearing (for antenna alignment) and the distance.  

With the option field Tx even/1st you can choose whether you want to transmit in the even 

time slots (0s/30s) or in the odd (15s/45s). The QSO partners are divided into two (disjunctive) 

groups. At even times you can reach one group, at odd times you can reach the other group.. 

Hold Tx Freq: either you transmit on the frequency of your QSO partner, which has the advan-

tage that he keeps the frequency "free" and immediately sees that someone answers on his 

frequency, but your own station is disabeld if the called one answers another station, or you 

select Hold Tx Freq and always transmit on the same (with the mouse in the upper window 

selected) frequency. This has the advantage that your own station is not disabled if the called 

station is still being called by another station. 

With Auto Seq the line sequence on the right hand side is automatically run through. 

With Call 1st the progam will respond to the first station that answers to a CQ call. 

The status bar displays,  

 whether transmission or reception is in progress,  

 which profile is selected,  

 which decoding method (Mode) is used 

 which line was just sent 

6.3 Backup and Log-File Upload 

6.3.1 Backup 

Hint: after a first configuration of the FT8--Box the SD-Card should be get a backup. 

With Win32DiskImager you can copy the SD-Image direct to your PC-harddisk. (Start 

Win32Diskimager with Adminstrator rights. 

6.3.2 Log-File Upload 

https://sourceforge.net/projects/win32diskimager/
https://ft8--box.hb9hci.support/images/%C3%BCbrige Felder.jpg
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Move your log-files to your PC via ftp (see 3.1). Best way: connect the FT8--Box with an 

Ethernet cable to your machine. The connet IP-address can be found via a WiFi-connection to 

the FT8--Box: Click on the blue VMC icon in the headerline: Now the IP-Adress of your ma-

chine is displayed. Connect from the browser of your machine via ftp://<IP-address> and you 

get access to the ADIF and LOG files on the desktop. 

6.3.3 SOTA csv Upload 

Reformat wsjtx.log with wsjtx2log in a csv formatted file. Upload this csv file into the SOTA 

database with the Raspi-browser (blue world icon in the headline). 

6.3.4 WSJT-X update 

Go to https://physics.princeton.edu/pulsar/k1jt/wsjtx.html and download 

 Raspberry Pi OS Buster, ARMv6, ... :      wsjtx_x.x.x_armhf.deb 

With x.x.x as actual version no. With dobble click on the .deb file installation starts. 

If your FT8--Box version is <= V2.2.2  you have to install also the us_locale. See: 

https://wsjtx.groups.io/g/main/message/21461 (be aware, there is a typo on that website. Use 

sudo dpkg-reconfigure locales in a terminal window. 

  

ftp://<ip-address/
https://physics.princeton.edu/pulsar/k1jt/wsjtx.html
https://physics.princeton.edu/pulsar/k1jt/wsjtx_2.3.0_armhf.deb
https://wsjtx.groups.io/g/main/message/21461
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7 Further information … 
For the practical operating technology I recommend my WebSite  

http://FT--8Box.HB9HCI.Support 

with further hints, videos and explanations. 

I gained Mountain Goat award (1000 

SOTA points) using only FT8-QSO's 

in just 5 months. The idea for this box 

was born after I had worn out two 

Windows tablets. A snowstorm on Le 

Honeck, FL/VO-002 meant the 2nd 

tablet was toast. So, it was clear: I 

don't want any cables on the display 

unit! Now the realisation of the FT8--

Box began. After all, it had to with-

stand snow, ice and rain. Some of the 

supply electronics were destroyed and 

sometimes a Raspi board was even 

torn away - this of course on top of 

the summit! (0 points). This was how 

the current solution turned out. It is 

not waterproof. But it should not fail 

with isolated splashes.  

Now I wish you a great deal of suc-

cess: the proof of the pudding is in the 

eating. It takes some time to get used 

to, but then it's a pretty safe way to get 

QSO's even under bad conditions. 

 

Vy 73 de HB9HCI, Andreas 

 

  

http://ft--8box.hb9hci.support/
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8 Trouble Shooting (Risiko-Management) 
Problem  Solution Descrip-

tion 

Assembly 

Missing parts Connect to HB9HCI.support   

Teile dit not fit read manual 2 

Parts still do not fit Connect to HB9HCI.support  

Start FT8--Box 

LEDs on the FT8--Box 

remain dark 

 

Power supply has an error: 

 Is the (small) USB plug in the side of the box? 

 Is the other end of this cable connected to a USB power 

supply? 

Is the power supply supplying enough power? 

(5V/200mA) 

5.1  

FT8--Box does not provide 

WLan Acesspoint 

 

 Check that the smartphone/iPhone displays FT8--Box 

as WLan network 

 Check that the LED's on the User Box blink from time 

to time 

 Has the IP been adjusted by software? (Undo setting) 

 

 

VNC 

No VNC viewer found on 

the smartphone/iPhone 

Has the App VNC-Viewer been downloaded and installed 

on the smart-phone/iPhone? 

 

VNC viewer starts, but no 

FT8 box is visible 

 

If the smartphone/iPhone is in the  

 FT8--Box Wlan booked in? 

 No FT8--Box network to be found (see above) 

 Log into FT8--Box - Network (Password: FT8--

Box) 
 Restart your smartphone 

 

3.2 

VNC comes with security 

prompt 

 

Acknowledge query. (No security is required for the con-

nection) 

 

 

VNC asks for server Log on to the server (FT8--Box) with Login: wsjtx Pass-

word FT8--Box 

3.2 

VNC cannot be used The operation of VNC takes some getting used to. The 

mouse works parallel shifted like a trackpad. To call up the 

keyboard or mouse buttons by tapping on the head bar with 

your finger, then an additional menu appears, with which 

you can use a keyboard and mouse buttons (as a translucent 

overlay) 

5.1  

see also 

OnBoard 

help on the 

Device 

VNC keyboard cannot be 

made to disappear 

Tap the back arrow at the bottom of the baseboard 

(VNC menu in the header can only be displayed without 

keyboard) 

 

FT8--Box screen suddenly 

disappears 

Smartphone/iPhone has started screen saver  

The WLan connection has been interrupted: The distance 

between the smartphone/iPhone is so large that the connec-

 

file:///D:/ham/FT8--Box/HB9HCI.support
file:///D:/ham/FT8--Box/HB9HCI.support
https://www.realvnc.com/de/connect/download/viewer/


HB9HCI    FT8--Box    DIY  V. 2.2.3en 

23 

 tion is interrupted: reduce the distance and re-register. 

An Ethernet cable has been plugged into the FT8 box. (Not 

every smartphone/iPhone can tolerate this) Plug, unplug 

again and reboot. 

Einstellungen in der FT8--Box 

The clock in the FT8 box 

(top right of the screen) 

shows wrong time 

 

FT8--Box synchronisieren 

Durch das Internet:  

Über Ethernet-Stecker (RJ45) verbindung mit dem Internet 

herstellen. (Synchronisation dauert einen Moment) 

Über das Smartphone:  

 Ggf. App installieren. 

 Starten und für GPS-Empfang sorgen. 

 In der App Zeitserver starten. 

Über das iPhone: 

o App installieren und starten. 

Anschliessend die Synchronistation mit SyncTime (Dop-

pelclick auf Icon) auf der FT8--Box durchführen. 

Synchronise FT8--Box 

Through the Internet:  

 Connect to the Internet via Ethernet (RJ45) connec-

tors. (Synchronisation takes a moment) 

Via the smartphone:  

 If necessary, install the App Zeitserver. 

 Start and ensure GPS reception. 

 Start the Time Server app. 

Via the iPhone: 

 Install and start the NTP-Time Sync app. 

Then synchronise with SyncTime (double click on icon) 

on the FT8 box. 

with GPS-Stick
4 

4 

Synchronisation with Sync-

Time fails.  

Program SyncTime cannot find a time server: Is the time 

server started in the Zeitserver app on Android? Does the 

smartphone have GPS reception?  

Is the NTP time server started on the iPhone and in the 

foreground? 

4 

wsjtx does not open.  

 

Possibly another instance of wsjtx is already running. 

Acknowledge error message with No 

 

Error in Sound Output/Input Soundcard is not selected in Setup. File => Open Setup 

Tab Audio and adjust Soundcard. (If no Soundcard is 

displayed, remove the SoundStick from the USB socket and 

insert it again and restart wsjtx). 

 

Rig Control Error Click on Ok and select the correct rig. Make sure that there 

is a USB connection to the rig. If necessary restart wsjtx. 

Next to the frequency selection must be a green S. 

The adjustment of the transceiver 

 

https://play.google.com/store/apps/details?id=app.timeserver&hl=de_CH
https://play.google.com/store/apps/details?id=app.timeserver&hl=de_CH
https://www.amazon.com/Fdrtew-Bulbs-Car-Film-Car-Holder-Car-Interior/dp/B0839HSR1P/ref=sr_1_9?dchild=1&keywords=u-blox7+gps
https://play.google.com/store/apps/details?id=app.timeserver&hl=de_CH
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 is a bit "fiddly" the first time:  

 PTT set to off. 

 VOX set to off.  

 Receiving bandwidth >3KHz 

 Displayed frequency is USB 

 Sound signal in the micro input should not over-

drive the transceiver. (Check signal with a 2nd re-

ceiver). 

 Sound signal from the phone output should be in 

WSJT-X at 30dB (reception bar at bottom left). (If 

overdriven the sound stick may become defective!) 

 

In Band Activity nothing is 

decoded 

Check that the synchronisation has worked. (Horizontal 

green lines in the waterfall window must be between the 

signals) Re-establish synchronisation. 

 

No FT8 signals appear in 

spectrum and waterfall 

despite connection to trans-

ceiver 

. 

Insert the connecting cable correctly between 

Transceiver                          Soundstick 

Sound out (Phones) <-----> Sound in 

Sound in   (Micro)   <-----> Sound out 

Is the correct frequency adjusted? 

Can signals be heard at all when the phone plug is discon-

nected? 

 

 

 

9 Checkliste (SOTA) 
  Tranceiver 

    Accu for Transceiver 

   Antenna 

  FT8--Box with GPS-Unit 

   USB-supply cable 

   Accupack with 5V USB power supply 

   Audio-cable Microphone (if sound is not transferred via USB) 

  Audio-cable phones (if sound is not transferred via USB) 

  SoundStick ((if sound is not transferred via USB) 

  USB-cable for Rig-control (optional) 

   Earplug (optional) 

   Audio-double plug for earphones to check the transmitted signal (optional) 
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10 Flowchart 

  

N 

N 

Smartphone/Tablet:  
start  Zeitserver app  

start server inside this app. 

IOS Android 

Checkliste 

geprüft? 

Operating 

System: 

Control 

Checklist  

FT8--Box: USB- 

Connect the power 

supply from the 

Accupack.  

(USB socket next to 

HDMI socket) 

Plug the SoundStick 

into the USB socket. 

Plug the audio cable 

(micro/phones) into 

the SoundStick. 
If necessary, plug in USB 

connection with transceiver 

 

Transceiver:  
Connect Accu 

Connect Antenna 

Conneting FT8--Box: 

Connect Audio-Phones cable 

Connect Audio-Micro cable 

Start 

iPhone/iPad:  
start: NTP-TimeServer  

App  (S7 Box) 

Connect Device via 

WLAN in FT8--Box Net 

Start VNC app 

In VNC with IP-address 

10.3.141.1 connect to FT8-

-Box  

Login: wsjtx 

Password: FT8--Box 

FT8--Box 

FT8--Box 

FT8--Box 

Desktop in 

VNC 

displayed? 

Prüfen:  

Gerät im FT8--Box WLAN? 

Kein FT8--Box WLan vorhanden? => 

Hat FT8--Box Strom? (Blinken ihre 

LED’s?) FT8--Box reset: 

Stromversorgung unterbrechen. 

VNC-IP-Addresse 10.3.141.1? 

VNC Login/Password korrekt?  

Y 

Check:  

Device in FT8--Box WLAN? 

No FT8--Box WLAN available? => 

Does FT8--Box have power? (Do 

their LEDs flash?) FT8--Box reset: 

Disconnect power supply 

VNC-IP-Address 10.3.141.1? 

VNC Login/Password okt?  

 Synchronisation via GPS failed?  

Double click on SyncTime Icon 

Is time now synchronised? 

No (enter time by mouse if necessary) 

Yes 

 

 Start LastQSO‘s  

Start wsjtx  all OK 

           No 

Wsjtx displays SoundCard-Errors: 

Select Driver via 

File=>Setup=>Audio  

Wsjtx displays RigError: 

Set Rig via File=>Setup=>Radio  

Wsjtx shows no signal in 

waterfall/spectrum  

Unplug/plug SoundStick and restart 

wsjtx 

Wsjtx sends no Sound to transceiver. 

Audio-cable connected (not crossed)? 

Callsign is set? 

File=>Setting=>General 

Transceiver-Micro sensitivity? 

Bingo! 

N 
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1 VNC: https://www.realvnc.com/en/connect/download/viewer/  
2
  Time Server App:  https://timeserver.app/ 

3
  NTP TimeSYNC: https://www.deepaso.com/app/tr/1089074515 

4
  Raspi 3B: https://en.wikipedia.org/wiki/Raspberry_Pi 

5
  Raspbian: https://en.wikipedia.org/wiki/Raspbian 

6
  WSJT-X: https://physics.princeton.edu/pulsar/K1JT/wsjtx.html 

WSJT-X can handle a wide range of modern digital modulation techniques (e.g. FT4, which 

runs on the same protocol as FT8 but at twice the speed). 

7
  Tests with DC-DC voltage converters have shown that chirping is then superimposed on the 

reception. (However, this need not be a hindrance.) With a 12/5 V DC converter you can 

then save the battery pack. However, an accupack is also sufficient when the battery in the 

smartphone is running low. 

8
  https://play.google.com/store/apps/details?id=com.realvnc.viewer.android 

9
  TimeServer: https://play.google.com/store/apps/details?id=app.timeserver&hl=en 

10
  Tiptop Audio Stackable z.B.: https://www.schneidersladen.de/de/tiptop-audio-stackcable-

55cm-yellow.html 
11

 https://www.g4ifb.com/FT8_Hinson_tips_for_HF_DXers.pdf 

https://www.realvnc.com/de/connect/download/viewer/
https://www.realvnc.com/en/connect/download/viewer/
https://timeserver.app/
https://timeserver.app/
https://www.deepaso.com/app/tr/1089074515
https://www.deepaso.com/app/tr/1089074515
https://de.wikipedia.org/wiki/Raspberry_Pi
https://en.wikipedia.org/wiki/Raspberry_Pi
https://en.wikipedia.org/wiki/Raspbian
https://en.wikipedia.org/wiki/Raspbian
https://physics.princeton.edu/pulsar/K1JT/wsjtx.html
https://physics.princeton.edu/pulsar/K1JT/wsjtx.html
https://play.google.com/store/apps/details?id=com.realvnc.viewer.android
file:///D:/Downloads/TimeServer
https://play.google.com/store/apps/details?id=app.timeserver&hl=en
https://www.schneidersladen.de/de/tiptop-audio-stackcable-55cm-yellow.html
https://www.schneidersladen.de/de/tiptop-audio-stackcable-55cm-yellow.html
https://www.schneidersladen.de/de/tiptop-audio-stackcable-55cm-yellow.html
https://www.g4ifb.com/FT8_Hinson_tips_for_HF_DXers.pdf

